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LAYERS IN PHOTOSHOP Version 21.1.3 

Layers and what you can do with them in Photoshop is one of the reasons it’s a top post processing 

software package. 

Layers show or hide portions of any layer. They target adjustments to where they are required. They 

combine pixels from multiple layers into one layer for focus stacking, exposure blending, etc. 

Basics 

Layers are like sheets of paper stacked on top of each other. 

The view is like looking on the stack from the top. 

If all the sheets are solid thick paper you can only see the top sheet (layer). 

If the top sheet is smaller than the next sheet you will see around the edges of the top sheet onto 

the 2nd sheet. 

To see through the top sheet, as with paper, you can cut a hole in it and see the layer below. 

Then to see further down you would cut a hole in the second sheet and so on. However, if the holes 

don’t line up you will not see though very far. 

Some layers are transparent (like tracing paper) so can been seen through. 

This is basically how Photoshop layers works. 

Photoshop unlike Lightroom is not a non-destructive process. To still have a non-destructive 

workflow, you use layers to make any changes / additions to the original photo. 

If I draw directly on the original photo and make a mistake, I can’t erase it as the eraser tool also 

erases the photo. Press Ctrl Z to step back / undo and you can step back many steps but it’s still 

working on the original photo not just keeping a record of the changes as in Lightroom. 

Layers keeps your adjustments separate and together with masks, which we will cover later, enables 

changes to be made to an individual action. If for example you made a specific change directly to the 

photo, then carried out many more changes and then noticed an error on the specific change you 

could possibly undo all the way back losing your subsequent changes, but with a layer and mask you 

can target just the specific change without affecting the other changes. 
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If we add a new layer, by clicking on the “New Layer” icon, which is the rectangle with a turned back 

bottom corner or the white lined black square with a + sign in the centre on some later versions of 

Photoshop (It’s on the bottom left next to the trash can), I can draw on this new layer with a black 

brush and this shows up over the layer below. 

I can then move this layer around (with the Move Tool) and erase it (with the Eraser Tool) 

independently of the layer below. If I click on the eye icon to the left of the layer thumbnail it is no 

longer visible. 

Be careful if you have the Auto Select box ticked. This is the box near the top left. With this ticked 

you move whichever layer you click on and you can end up moving layers that you didn’t intend to 

move. I generally have this un-ticked. 

If you want to delete a layer just select it and press delete or drag it to the trash can. If you delete 

the wrong layer hit Ctrl Z to undo. 

Some layers can be photos, drawings, etc and other layers can be the transparent sheets noted 

above that you can see through but can add things onto. These look like checkerboard pattern 

sheets. 

To copy a layer, click on the layer thumbnail so its selected. Then hit Ctrl J and the copied layer will 

appear above the original layer. 

To copy a selection, first make a selection with any selection tool and then press Ctrl J and only the 

selection will be copied and it appears on a new transparent layer. 

To copy another photo into image and the layers stack, open the second photo in Photoshop, go to it 

by clicking on the name in the titles row above the photos if it’s not already selected and then in the 

Select menu click on All to select all of the photo, then press Ctrl C to copy this selection, go back to 

the original photo by clicking on its title and press Ctrl V to paste the second photo onto the image. It 

will appear both on the image and in the layers stack. If you haven’t got it in the correct place in the 

layers stack just click and drag it up or down until the double green lines appear and release the 

mouse. 

If you want to select something from another image its best to add this to a new transparent layer 

rather than adding it to the original photo. This allows you to move / edit the new item 

independently from the original photo.  

To add a new layer (not a copy of a layer), click on the new layer icon on the bottom right (it was a 

page with a turned corner but in the latest versions it’s a rectangle with a + sign in it). This will bring 

up a transparent layer. 

You can add various adjustments to the photo that are similar to those in Lightroom. It’s best to do 

these via adjustment layers. The various adjustment layers, not surprisingly, appear as layers on the 

layers panel. These can be selected and moved around in the layers stack as required. 

To make the adjustment only affect the layer below it, select the adjustment layer thumbnail and 

then click on the link symbol (it’s a bent line with a down turned arrow). 
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You can group layers to avoid too much clutter in the layers panel. 

To access the layers detail menu double click on the right of the layer in the layers panel. This opens 

up menu which includes the Blend-if sliders. 

If using something such as Topaz AI Denoise its worth copying the layer (Ctrl J) to be denoised as 

Topaz AI directly alters the layer so if you don’t like the result is harder to undo. Then label the layer 

so it’s clear that this is the denoised layer. 

You can turn a layer on or off by clicking on the eye icon to the left of the layer. 

You can move layers in the stack by clicking and dragging them into position. The Background layer 

(the original / bottom layer) cannot be moved around. If you want to convert the background layer 

to a regular layer press Alt and double click on the layer and it will be converted to a regular layer. 

To move a layer around within the image, select the layer and use the Move tool and drag the layer 

around. 

You can name / rename a layer by double clicking on the name in the layer text box and change the 

name of the layer. If you have a lot of layers this can be helpful to avoid confusion. 

You can also group layers together. It’s like a folder with the layers inside. Click on one layer, then 

Shift click on the next layer and they will both be selected. Then go to the “Layer” menu and go to 

“Group Layers”. The quick way is to just press Ctrl G. Click on the little arrow beside the group folder 

symbol to open the group. You can rename the group. To take a layer out of the group just select it 

and drag it out. 

If you want to highlight a layer Right click inside the layer thumbnail on the layer panel and select a 

colour. 

To bring in another photo to be a new layer open the second photo in Photoshop and in the “Select” 

menu select “All”, then Copy, go to the main photo and when open press “Paste”. The other way is 

to go to the “Select” menu and select “All”, then Ctrl C, go to the main photo and press Ctrl V to copy 

it in. A quick way is to just click and drag the second photo into the original image, wait for the main 

photo to open and let go of the mouse and it will appear as a new layer. 

When coming from Lightroom you can select two or more photos and then from the “Edit” menu 

select “Edit as layers in Photoshop” which is at the bottom of the menu list. 

To resize a layer, go to the “Edit” menu and select “Transform” and select “Scale”. Handles will 

appear around the image and you can drag these to the size you want. You can select rotate or one 

of the other options here. To get out of this hit “Esc” or the hit “Stop sign” circle with diagonal line 

across next to the tick at the top. 

Another way is press Ctrl T to get “Free Transform”. When you drag the handles, it will adjust the 

ratio of the layer. If you want to maintain the original ratio hold down shift when dragging. 

To add a mask to a layer, select the layer thumbnail, click on the add mask icon (White rectangle 

with a black circle in the middle) on the bottom right. 
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If you need to save part way through and you have arrived from Lightroom just go to “File” menu 

and hit “Save” then it will save as a Tiff file and place the image back in Lightroom next to the 

original photo. If you are just working in Photoshop you can select “Save As” and let Photoshop save 

it as a PSD file. Both retain your layers so you can go back and re-open at any time and carry on 

working using the layers. If you save as a JPEG the layers will be flattened and gone. 

To change the Opacity of a layer, adjust the slider above and to the right of the layers. Remember to 

select the correct layer first. As you move the slider to the left you will be able to see through the 

layer to the layer below. You can hover the curser over the word Opacity and a little hand with two 

arrows will appear and you can drag with this. You also type the % directly into the box. 

You can change the opacity of a Group as well. Click on the group itself and change the Opacity of 

the whole group. Or move the whole group together with the Move tool. 

The most common error is to have the wrong layer selected when you try to do things and wonder 

why they are not working. 

Layers Panel 

Now we can look at the Layers Panel itself. 

You can click on the word Layers and drag it off the side of the main layers panel. Each panel has its 

own menu which is the box with 4 white lines in it in the top right corner. I generally don’t do this 

and leave everything in the layers panel. 

To change the size of the layer thumbnails, right click on the selected layer thumbnail itself and this 

opens up a menu known as Panel Options and select the size you want. The default seems to be 

different on the various versions some is small and some medium but the larger size does help to 

see what is going on so I would recommend using this or the medium one. If the layers panel gets a 

bit too full you can always go back and select small. I don’t change anything else in the Panel Options 

menu. 

There is a Menu item called Lock Layers. This is also a line on the panel itself directly above the layer 

thumbnails. You can lock the various attributes of a layer. For example, if you don’t want a layer to 

be accidently altered you can click on the brush symbol and the pixels on the layer are locked. I don’t 

use these functions very often. 

Then there are Convert to Smart Objects, Blending Options and Create Clipping Masks, Merging 

Layers, Flatten Image. These are all very useful but we will come to them later, possibly in other 

guides. 

You can link layers by selecting the layers by shift clicking as noted above. When the layers are 

highlighted so even though they are not Grouped you can now move them together, reduce Opacity 

together etc. 

This is a temporary link so as soon as you click on another layer the link is broken. If you want the 

link to be maintained click on the Chain icon at the bottom left of the panel and this symbol will 

appear on the selected layers. They are now linked even when you click onto another layer. To turn 

this off Shift click on the layers and then click on the Chain icon at the bottom left of the panel. 
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This can be helpful if you have a selection or mask on another layer and you move one of the layers 

the selection or mask will no longer be in the correct location so linking them can be very useful. 

Properties Panel 

The next section to look at is the Properties Panel. There is an icon 2nd from the top. It’s a cube with 

two white squares on the right and a white rectangle under. If you can’t find this go to the 

“Windows” menu on the very top line and select Properties. 

You can open the properties panel by double clicking on the layer icon. 

This layer changes depending on what’s in the layer selected. For example, if the layer is a text layer 

then text options will appear, if it’s a Hue/Saturation layer then the relevant panel will be shown 

allowing you to adjust the settings. 

Adjustments to photos can be made in Photoshop. Go to the “Image” menu, “Adjustments” and you 

will see the whole list of possible adjustments. 

These settings are just like the adjustments in Camera Raw and Lightroom and it’s probably best to 

do these there rather than in Photoshop but to avoid going back if you missed something you can 

make adjustments here. 

However, remember Photoshop is a destructive workflow and Ctrl Z undo is not considered non-

destructive. So always create a copy layer before carrying out any adjustments but even this is not 

really helpful as you can’t adjust the change. 

Making the layer a “Smart object” does enable changes to be made and we will get to that later. 

Adjustment layers can be adjusted as many times as you like. So, this is where you use the 

“Adjustments” tab on the layer panel, which is towards the top under the histogram, next to 

Libraries. This will open up the Adjustments panel with the various icons for the adjustments. You 

can hover over each icon to see what it does. These are also accessed by using the half white / half 

black circle icon on the bottom right. This icon also accesses the solid colour layers. 

If you click on the “Brightness / Contrast” Icon it opens up a new layer and a new panel to the side 

where you can adjust these settings. The new layer has a mask attached and we will talk about 

masks later. The advantage to using this is that when finished editing you can go back by double 

clicking on this new layer (not the mask) and it opens up the properties panel for “Brightness / 

Contrast” again so you can adjust it. 

If you only want the adjustment to apply to the layer immediately below the adjustment click on the 

link symbol (It’s the square with the bent arrow sticking out and down to the left of the square) 

which is the symbol to the bottom left of the adjustment panel menu. If you have closed the 

adjustment panel menu double click on the layer thumbnail to open it again. 

When clipped the layer thumbnail jumps to the right and the clipping icon shows. You can also clip 

by Alt clicking on the line between the two adjacent layer thumbnails, this is a toggle so Alt click 

again to remove. With Alt key pressed down you will see the link icon as you move over the line 

between the two layers. 
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To close any adjustment panel, click on the >> symbol at the top right of the pop out panel. 

Colour Lookup Adjustment 

There is a Colour Lookup item on the Adjustment Layer list accessed from the Adjustment layer icon 

on the bottom right or the Colour Lookup Icon (a rectangular grid) from the Adjustments tab 

situated under the histogram, which can show various colour tint options. These are known as 

Colour Lookup Tables (LUTs). If you open it make sure the top item 3DLUT is selected and click on 

the top item 3DLUT File box and various “looks” are available to try. If you like the effect but think 

it’s too much you can always reduce the opacity to tone it down. 

Some of these property panels work better than others and I generally use the Brightness / Contrast, 

Hue/Saturation and solid colour more than anything else. 

Type layers 

Type layers are not surprisingly where you can add text to your photos. 

Click on the Text tool or hit the letter T on the keyboard and the text tool is activated. There are 

other text tools available if you go to the text tool and hover over the small triangle they will appear. 

Use will probably only use the top one.  

You can click on the photo where you want the text to be and just start typing or click and drag to 

create a text box and place the text in there. 

Hitting the esc key will undo your typing. 

The size of the image will dictate how large your text needs be. Sometimes you start typing and it’s 

so small you can’t even see it. Place the curser over the two T’s to the left of the font size box and 

the hand with the two arrows will appear then just drag to the right to increase the font size and to 

the left to reduce. You can go much larger in size than the size listed in the text size menu. 

Default text appears to help get the size right before you start to type. 

There are justification icons, font type, size and style. 

The text will automatically pick up the foreground colour but you can change it with the colour 

square, which is next to the justification icons. 

Click on the tick icon when finished. 

If you click on the Character / Paragraph icon 2nd from the right it opens an adjustment panel and 

lots of text character and paragraph adjustments are available. 

Double click on the text layer thumbnail to select the text you want. This is why it can be useful to 

have different sections of text on different layers so they can be worked on independently. 

As the text is on a layer you can grab the move tool and move it around. Once you were happy you 

could link the text layers or group them. 

You can use the Free Transform tool (shortcut is Ctrl T) to move and manipulate it. 
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So, everything you can do to a layer you can do the text. However, this is a layer you can go back and 

change. 

Shape Tool Layer 

Not used much for photography but you could select this tool and draw a shape and then add text 

over it. For example, select the rectangular shape tool drag out a rectangle (Hold shift whilst 

dragging for a square) and the shape will be on a separate layer. 

You can change its colour and add boundaries etc. 

If you finish but then want to alter it just open its properties panel by clicking on the properties icon 

(Icon 2nd from top on the bar to the left of the layers panel) 

You can then move some text over it if you want the text to sit on a banner. If you want the banner 

to be translucent just reduce the opacity of the shape until it’s as you want it. Then link the text layer 

with the shape layer to keep them together if you need to move them. 

If you prepare the shape first and then type over it the curser will change to a circle from the normal 

text square curser and this means Photoshop will constrain the text to the shape. If you don’t want 

that just hold down shift until the curser changes back to a square then release and type normally 

and the text will not be constrained. 

Text and shapes are vector graphics and are infinitely scalable unlike the photo itself. So, it won’t 

pixelate as you increase their size. 

Aligning Layers 

When the move tool is selected various aligning icons appear along the top of the viewing panel. 

Until you tell it, Photoshop won’t know what to align things with so the icons will be greyed out. 

Create a selection and if you want this to apply to the whole image go to the Select menu and select 

“All” or press Ctrl + A. This will put a section around the edge of the whole image and the aligning 

icons are now available. You can scroll across the icons and select the one you want. You can use 

two one after the other as well. 

When finished you could go back to the Selection Menu and Deselect or just press Ctrl + D. If after 

doing this you want to move it again you can by just using the move tool. If you want to keep it fixed 

in one direction (say centred) hold Shift whilst moving and it will not drift off line. 

You don’t have to “select all” you can create a selection using the other selection tools such as the 

Rectangular Marquee tool. 

To use one layer as the selection for another layer. For example, text on one layer being centred on 

a box on another layer (usually a layer with only a box on it). Click on the first layer say with the text 

and shift click on the layer below with the box and both will be selected and the icons become 

active. 
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You can align two photos by having them on two layers. Let’s say you have one great photo of a 

footballer but the ball is out of shot but the ball is in shot on another photo that’s not quite as good 

because the players hand went in front of their face. 

Open the first photo with the ball and then go to the second one “Select All, copy it with Edit menu 

and select Copy or Ctrl + C, then go to first photo and using the Edit menu and Paste, to paste it in or 

use Ctrl + V. 

You should now have two layer one with each photo. If they are in the wrong order drag the one 

with the ball to the bottom if it’s not already there. 

Click on the top layer and Shift click on the second layer to have them both selected. Then go to the 

Edit Menu and go to Auto-Align Layers. A new panel will open with 6 options to choose from but 

generally you only need to use “Auto” and select Ok. 

Photoshop will move both layers to align them. 

Then you can use layer masking (which we will look at later, which is the better non-destructive way) 

to reveal some of the layer below that you may want to see or just in simple cases you can use the 

“Eraser” tool to brush away the top layer to reveal the ball. 

Reduce the top layer opacity to see where the ball is then using the Eraser tool to rub away the top 

layer to reveal the ball and then put the opacity back to 100%. You can also rub away any other 

things that are not quite as they should be. 

Then finally get the crop tool and drag in the edges to remove the out of frame sections caused by 

the alignment process. 

Focus Stacking 

This can be done manually by taking say two or three photos, one focused on the background, one 

focused on the foreground and possible another focused on the middle ground. 

Then load them into Photoshop as layers. Using this from Lightroom select all the photos, right click 

and from the menu select the bottom line to edit as layers in Photoshop.   

You do this manually by either erasing away the part of the layer that’s not sharp to expose the layer 

below (this is destructive) or you can create a layer mask (which are explained in another help 

document) by clicking on the mask icon in the bottom right and painting over the mask with a soft 

black brush on the areas not sharp on the relevant layer to make it invisible on that layer thus 

exposing the layer below. 

I recommend using the layer mask method as you can always go back and adjust this by using a soft 

white brush to repair the white mask. 

Photoshop has a feature that does this automatically. In the Edit Menu there is a feature called 

Auto-Blend Layers. 

Photoshop does a reasonable job but there are better proprietary focus stacking software packages 

especially for macro work if you want real precision. 
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However, this feature is useful if say in a landscape photo you want really sharp front to back 

sharpness but you want Photoshop to do the work for you. 

This is also useful in macro photography where you can have several photos all with slightly different 

focus points but a proprietary software package may be more accurate for macro work. 

Get the photos into the same document as we did in the above example. 

Select the top one and Shift click on the other one or other ones. 

Then go to the Edit menu and select Auto-Blend Layers, then in the pop-up menu, select Stack 

Images, leaving the two options at the bottom turned on. If it brings up an error message ignore it. 

This process will add a layer mask to the layer(s). 

Duplication 

To duplicate a photo, go to the Image menu on the top row, Select Duplicate and on the pop out 

menu click ok and it will make an exact duplicate of the photo and this will be is if it was a new photo 

you had imported. 

Smart Objects / Smart Filters 

These are basically the same. 

These allow you to go back to adjust the settings on somethings that otherwise would be fixed. 

With the layer selected go to the Layers menu on the top row, select Smart Objects, then Convert to 

Smart Object. 

This will add a small icon in the bottom right hand corner of the layers panel thumbnail. 

If you reduced the size of the image and it wasn’t a smart object you cannot bring it back in the same 

form as when you try to do so you are upscaling the shrunken image thus losing its full resolution. If 

it was a smart object it remembers its original size and you can just go back to full size and it retains 

full resolution.  

You can go to this via the Filter menu on the top row, select Convert for Smart Filters. This will bring 

up a message telling you it’s going to be converted into a smart object, just click ok. 

Then say you go to the Filter menu and select Stylize and Oil Paint. You can then make some changes 

then click ok. A normal filter would have applied this change to the layer itself but the Smart Filter 

created a Smart Filter below the layer which you can access by double clicking on its name and 

change the settings. 

The Smart filter will be there after you save it as a PSD file so you can change it when you re-open 

the file. 

You can also change the Smart Filters opacity and blending options separately from the main filter by 

clicking on the small icon to the right of the Smart Filter (Two horizontal lines with two triangles) and 

this opens up the properties panel for the Smart Filter. 
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You can also add additional Smart Filters and they appear stacked under the first one. 

Smart Filters have their own eye icon to the left of their name to turn the effect on or off. 

To delete a Smart Filter right click on its name and then select Delete Smart Filter. 

Merging / Flattening 

Go to the Layers menu on the top row and go down to the bottom and you will see Merge Group; 

Merge Visible; Flatten Image. 

The simplest option is to flatten everything. This combines the layers into one layer. Although this is 

simple and reduces file size it doesn’t allow you to go back and amend the original layers. I therefore 

don’t use Flatten very much. 

If you want to send the photo to someone but don’t want to send the layered image save as a JPG 

instead of the normal PSD. Go to File menu, select Export and then Quick export as JPG. A JPG is 

automatically flattened as it doesn’t support layers. 

Merge Visible is similar to Flatten but just flattens the visible layers. Therefore, if you had turned off 

a layer by clicking on its eye icon and then went to Merge Visible it wouldn’t become part of the 

flattened image. This has the same shortcomings as Flatten in that the layers are lost. 

Merge layers will merge selected layers. Selected the first layer by clicking on it and then shift click 

the second layer and then select Merge Layers and they will be combined into one layer. This can be 

used to simplify your layers panel when it becomes to complicated but again be careful as once the 

file is saved you can’t go back. 

If you have group of layers, click on the group and then when you go to the Layers menu there will 

be an option to merge the group, without merging or flattening the rest of the layers. 

If you have layers and you want to make a combined layer of everything on them above these layers, 

select the top layer and press Ctrl, Alt, Shift, E at the same time (Command, Option, Shift, E on a 

Mac) and a new combined layer will appear but leave the original layers intact below. This can then 

make those final changes easier to do on one layer. 

Layer Styles 

To access Layer Styles, click on the fx icon on the bottom right next to the Mask icon. 

This opens up the Layer Style menu. 

Layer Style works on objects within an image that is on a separate transparent layer or Text on a text 

layer. The object generally has to be smaller than the overall image. This could be a logo for example 

where you Bevel & Emboss something or add a drop shadow. 

There is a preview box that if ticked shows you on the object what the effect is. 

You can move the sliders on depth, size, soften, opacity, etc. 
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This adds a Layers Style list below the layer thumbnail with the effect and you can double click on 

the effect name to reopen it to make further changes. 

If you want to remove the effect just click on the effect name and a menu will pop up, scroll down 

and click on Clear Layer Style and the effect will be deleted. 

If you use the main layer Opacity slider (the one you use for normal layers) you can alter the 

transparency of the object but if you go to zero its completely invisible. However, if you use the Fill 

slider instead (that sits just below Opacity) and go to zero the Bevel & Emboss for example is still 

visible so you get an outline of the object but the object itself is transparent. 

If you use it on text for example you could add a drop shadow. You can then change the blend mode, 

opacity, spread, angle, etc. If you move the cursor over to the text whilst the Layers Style menu is 

open you can drag the drop shadow around rather than using Distance & Angle. 

Stroke adds a line around the text for example and you can change the line colour. 

You can add multiple effects just by ticking the effect box in the menu. 

Layer Shortcuts 

Ctrl J - Copies the whole image onto a new layer (provided there is no selection on the layer) 

Ctrl J - If there is a selection then it just copies the selected area onto a new layer within a 

transparent layer. 

T - This will add a text layer 

Ctrl, Alt, Shift, E - To merge all the layers into one new layer which will sit on top of the layers below. 

Alt Click on eye icon - Hides all other layers so only the clicked layer is visible. Repeat to make them 

all visible again. 

Layer Masks 

Masks are attached to layers and appear to the right of the layer. 

There are two types of layers that you can use masks on. These are pixel layers (normally photos, 

solid colour layers or blank layers we have painted on) or adjustment layers (layers that adjust 

colours / brightness, etc). 

Masks are often associated with selections and to understand selections understanding masks is 

very important but masks have other functions for example using a brush to edit the extent of an 

adjustment. 

An important part of masks is that it enables changes to be made to an individual action. If for 

example you made a specific change directly to the photo, then carried out many more changes and 

then noticed an error on the specific change you could possibly undo all the way back losing your 

subsequent changes, but with a layer and mask you can target just the specific change without 

affecting the other changes. 
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Masks are how we make things visible or invisible on a layer. You can do the equivalent of cutting 

out holes in a layer as you would with a paper layer. To do this you use the brush tool painting in 

black normally on a white layer mask or white on a black layer mask. 

Layer masks are dealt with in more detail in a separate help document. 


